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Abstract - Covid-19 pandemic affects our life suddenly and dramatically. The most affected area was our 

teaching methods. Students and teachers move to distant learning without good experience and 

background especially for non-IT teachers. Technology enhanced learning has attracted increasing 

attention of educational community focused on improvement of traditional classroom learning/online 

classes. Augmented Reality(AR) technology enhances user’s perception of reality by augmenting 

computer- generated components and reinforcing the retention of critical knowledge that may 

otherwise widen student knowledge gaps. AR in education can conceivably impact the student 

participation, information transfer and skill acquisition, hands on digital experience with the education 

when there is no practical exposure to laboratories. 
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I. INTRODUCTION 

Augmented reality offers a live, direct or indirect view of a physical, real-world environment whose 

elements are augmented by computer-generated components such as audio, video, 2/3-D graphics, GPS 

data, etc. Unlike virtual reality that simulates a virtual environment to replace the real one and 

completely immerses users inside the synthetic environment, AR supplements the surrounding real 

world by augmenting it with virtual, computer-generated  overlay added to the physical environment 

through a auxiliary sensory mechanism and allowing users to see the real world with virtual objects 

superimposed on the real world. AR applications generate and enable a common space where virtual and 

real objects coexist in a seamless way, and enhance user’s perception of reality by providing them with an 

interactive environment and digitally manipulated lies between the AR and the physical environment 

and offers more enhanced experience with the examined reality through the artificial components added 

or blended into the scene to improve its perception. It has been shown that AR technologies can help to 

increase learning motivation of students and enhance the quality of learning experience[2]. 

 

The adaptive technological solutions for education have been increasingly popular. Education can be 
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rather flexible when it concerns the methods of increasing student engagement and interest in learning. 

Online courses, chat bots, gamification, and, of course, virtual and augmented reality – today you can 

find all of them in the curricula of both primary schools and universities. The proposed system consists 

of a set of components centered on the mobile phone to exploit its sensory and data processing 

capabilities. The AR technology is enabled through the interaction of a set of predesigned cards with 

chemical substances or element structures printed on and the AR smart phone application that visually 

senses the real world with the camera and live augmenting the perceived view with the virtual objects. 

The mobile application has been developed using Unity engine and Vuforia AR SDK and can run across 

multiple platforms like IOS, Android, WebGL etc. 

 

The main objective of this work is Quality Education and Reduced Inequalities by improving the 

standards of education especially online classes using the cut-edge technology called Augmented 

Reality[3]. Augmented reality can help make classes more interactive and allow learners to focus more 

on practice instead of just theory thus increasing the student’s productivity. 

 

II. RELATED WORK 

 

J. Martín-Gutiérrez et el [8] proposed the work to measure the learning motivation of undergraduate 

health science students at the University of Cape Town (UCT) before and 

after using a particular AR mobile application. The main research issue was the differences in student 

learning motivation before and after using the AR mobile application. The main research question was 

underpinned by several sub questions examining how the attention, relevance, confidence, and 

satisfaction aspects of learning motivation were affected by using the AR mobile application. D. A.  

Budiman et el [6] AR no longer requires specialized equipment and may easily be used through 

computers or mobile devices. A lightly AR supplements the real  world with a relatively small amount of 

virtual information, while a heavily AR contains frequently accessible virtual information. The amount of 

virtuality within the real world determines the type of technology required to support the  AR, as 

different display and tracking technologies result in different degrees of immersion. Immersive 

technologies such as head-mounted displays are used to support heavily AR and foster more immersion 

than mobile devices, which can support lightly AR. An example of a lightly AR would be the Pokémon GO 

mobile application, which can be used through a Smartphone. An example of a heavily AR is the Star Wars 

Jedi Challenges mobile application which requires the user to use a headset. Many people now own 

mobile devices and therefore have access to AR. The use of AR for learning has been made more feasible 

due to advances in mobile technology and the increased use of smart phones. Smartphone and tablets are 

ideal to facilitate AR experiences, due to fast processors, graphics hardware, and various onboard 

sensors[5]. 

The educational value of AR is closely linked to the way in which it is designed, implemented, and 

integrated into formal and informal learning environments. An important consideration is how AR 

technologies support and afford meaningful learning. Considering AR as a concept  rather than a certain 

type of technology would be productive for educators. The involvement of educators is important to 



4969 | D.Roopa                                    Impacting Online Classes With Augmented Reality Based 
Education 

 

facilitate the development of favorable AR applications. Some of these AR applications have been used in 

previous studies. Gopalan et al.[4] tested the impact of AR enhanced science textbooks on lower 

secondary school students in Malaysia. Chiang et al. [10] tested the use of an AR based mobile learning 

system for natural science inquiry activities on fourth-grade students in Taiwan. The system guided 

students towards target ecology areas and displayed the corresponding learning tasks or related 

learning materials. Akçayır et al. tested the use of an AR enhanced laboratory manual in science 

laboratories on first-year students in Turkey. This study tested the impact of the Anatomy 4D mobile 

application on the learning motivation of health science. 

M. Sirakaya et el [3] proposed the idea aimed to identify the trends in the studies conducted on 

Educational Augmented Reality (AR). Analyses displayed that the number of educational AR studies has 

increased over the years. Quantitative methods were mostly preferred in those articles and educational 

AR was often found to be used in science education (physics, chemistry and biology), engineering 

education and medical training. The reviewed articles showed that "undergraduate students" were used 

as samples for most of the time, the most often preferred sample size was between "31-100" and 

"surveys" were the most utilized data collection tools. While the majority of the articles used marker-

based AR as AR type, mobile devices were utilized in many of these articles as the delivery technology.  

Kuang, Y., &Bai, [1] Some very intuitive, interesting things, life experience can be naturally recorded in 

the mind of children, and for children in the preschool stage, the way of image memory occupies a very 

large proportion, the ability level of memory words has gradually developed. Children in this age group 

have an unintended memory advantage, but intentional memory increases gradually as they grow. 

Their group has the following three typical memory development characteristics: (1) with the brain 

easy to excite, but also very unstable: (2) The performance is easy to remember, but also easy to be 

forgotten. (3) The accuracy and consolidation of memory is poor. It is according to the characteristics of 

children's psychological development, the application of augmented reality in the field of early 

childhood education covers the "multi-modal visualization of theoretical concepts and traditional 

multimedia textbook interaction Theory and practical exploration" and so on, by fitting the 

characteristics of children's psychological development, can make the APP better and effectively 

enhance the process of young children learners to explore, discover the knowledge. Individual  with self-

motivation always can find a motive and intensity without expecting external encouragements to complete a 

task even though the task is challenging. In contrast, negative motivation  illustrates the behavior is 

motivated  by  expectation  and  fear of not able to achieve the aimed outcome. Fear considered as a 

powerful motivator, notably when the fear is regarding our survival and future Endeavour’s [14]. 

 

V. Gopalanet et el., [4] There are several motivation theories for instance the instinct theory which 

is considered  as the root for all the motivation and motivation is to survive. The theory depicts that 

biological or genetic programming causes the motivation to occur and all human beings  share the same 

motivation as all of us are sharing the similar biological programming . Then, the incentive theory is 

among the major theories of motivation. This theory illustrates the desire to motivate behaviors for 

enrichment or incentives , which means we are motivated to  perform actions because of internal 

desires and desires, yet at other times, our behaviors are passionate by a desire for external rewards. 
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Besides that, the arousal theory illustrates the maximum level of eagerness or arousal. People with high 

optimum levels of arousal will perform high enthusiastic behaviors, like bungee jumping, scuba diving 

and so on. While the rest of us are feeling contented with less exciting and less unsafe activities. The 

theory depicts the ability to do what needs to be done, without influence from others or circumstances. 

 

III. SYSTEM ANALYSIS 

 

a. Existing System 

In existing system, the user should create some images with characteristic patterns. He should also 

prepare some virtual models, described in VRML format. These models are later associated to the 

corresponding characteristic patterns, The camera supplies the frames to an application which searches 

the current frame for known patterns, which are stored in a database of registered patterns[9]. If a 

match is found the software displays the virtual object attached to the found marker. Our entire system 

is based on recognition of fiducial rnarkers. Fiducial markers are selected points on an image that are 

used as a frame of reference in locating objects. Our application (based on the ARToolKit library) then 

searches each frame for registered pattems and displays virtual objects associated with them. If we move 

in the real world the real objects signed with fiducial markers the same movements, translation or 

rotation in the space, will be made on the associated virtual objects. This means that we could put 

fiducial markers on Here, the real objects that are visualized on the screen and on these objects could be 

superimposed additional artificial or even abstract objects that will give a deeper explanation of some 

presented phenomena but no interactions. 

 

• In this system, the captured image or video frame is matched with pre-stored images to know the 

position and the kind of virtual object that is to be blended in the view of real scene. 

• As a result, an augmented image appears on the device (i.e) only the 3D view of the image is be 

displayed. 

• Existing System has problems with sensitivity trigger 

 

In existing system architecture it is seen that images have been collected using cameras and sensors in  

many fields. The image processing (recognition and tracking) methods have been applied on the 

collected images and this data has been used in augmented reality. In this study, an image processing-

based module has been developed for augmented reality devices[7]. It is aimed to improve visual 

quality by using the developed module on the augmented reality devices. The existing system 

architecture is shown in the figure 1. 
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Figure. 1 Existing System Architecture Limitations 

• Non-interactive models 

• Extremely costly when using AR HMD’s 

• People with hearing aids find it difficult to understand the non interactive models 

 

b. Proposed System 

The proposed aims to improve teaching quality in education via interactions and other components 

using augmented reality with Unity and Vuforia. Feature extraction and pre- processing is performed 

on the images using basic image processing methods. Google search feature along with audio source 

components have been included. Various techniques have been adapted to ensure the user interactivity 

with the 3d objects. 

 

Proposed System Architecture 

In the proposed system, Interactive 3D Experience for inquiry based learning for abstract concepts, 

Promoting experimental learning through which students can perform lab procedures with event-

action sets(using c# in Unity). External links to know more information (Google and YouTube). Thus 

gives an immersive experience. The event action sets are simulated using C# in the Unity Platform. 

Vuforia Database stores the target images, developer should ensure that the image rating is 4 and above 

so that the feature points in it are correctly read and recognized by the image processing algorithm. Ray 

casting technique was used to for the touch detection on the 3D Models this written  code works well in 

desktop system and Mobile phones. Thus our proposed system seems much better and appealing then 

the existing one with the various techniques adopted. 

 

Figure. 2 Proposed System Architecture Main benefits are 
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• Inexpensive for the users. 

• Children with hearing aids get clear foot prints of the study concepts. 

• Can be used in any smart phone with Android version of 6+. 

 

IV. SYSTEM DESIGN 

        This chapter describes the design phase of a work which is divided into following 4 modules 

1. Integration of Platforms 

2. Scene Navigation 

3. Scene Development 

4. Audio, Google Redirection. 

It briefs about system design of each module along with its functionalities. The entire process flow and 

its interaction with the system components are explained. 

    ntegration Of Platforms 

Module involves the installation of Unity 3d engine, Java JDK, Android Studio, Microsoft Visual Studio 

and Blender (for modify/edit/create of 3D Models). The next  step involves the integration of everything 

inside Unity 3d. Prerequisites include creating a Vuforia Developer account, creating a Database in it for 

storing the image targets and then generating a license to build our project. 

 

Steps For Integration Of Platforms 

Step 1: Install the above specified applications in the system. 

Step 2 : Inside Unity Player settings from Edit > Project Settings, then select the Player category, and 

select the tab for the mobile device you are building to. Under the XR Settings panel, enable the Vuforia 

Augmented Reality Support property. 

Step 3: Go to File -> Build Settings -> Android and click Switch Platform. 

Import or open the project you have just created with Unity Enable Google Android  Project. 

Click Export. 

Step 4: In Unity, go to Edit > Preferences, and make sure that Visual Studio is selected as your 

preferred external editor. Next, double click a C# file in your project. Visual Studio should 

automatically open that file for you. You can edit the file, save, and switch back to Unity to test 

your changes 

Step 5: Store newly generated solutions. In Unity, go to Edit > Preferences, and make sure that 

Visual Studio is selected as your preferred external editor. Next, double click a C# file in your 

project. Visual Studio should automatically open that file for you. You can edit the file, save, and 

switch  back to Unity to test your changes 

 

b. Scene Navigation 

The Scene view has a set of navigation controls to help you move around quickly and efficiently. 

They are Scene Gizmo, Move, Orbit and Zoom tools  and the Center too price displayed. The data 

flow diagram for Scene Navigation is shown in the below Figure 3 
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Figure 3 Data Flow Diagram for Scene Navigation 

 

c. Scene Development 

Scene Navigation is mainly used to switch between the multiple scenes in our application such as Home, 

Geography, 7 Wonders of the world, Biology, Chemistry and Flame Test. Scenes contain the objects of 

your game. They can be used to create a main menu, individual levels, and anything else. Think of each 

unique Scene file as a unique level. In each Scene, you will place your environments, obstacles, and 

decorations, essentially designing and building your game in pieces. Fig 4.a,b,c shows the Augmented 

Reality view for Geographic scene generated, Ribcage view and Chemistry Scene complex Structure for 

the marker respectively . 

 

       Fig.4.a Geography Scene 
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Fig.4.b RibGage Scene  

 

Fig .4.c Chemistry scene Complex Structure 

 

Steps Involved In Developing a Scene: 

Step 1: To open a scene, in order to begin or continue working within that scene, double-click the scene 

asset in the Project Window. If your current scene contains unsaved changes, you will be prompted to 

save or discard  the changes. 

Step 2: Depending on what kind of object you want to create, you add different combinations of 

components to a Game Object. You can think of a Game Object as an empty  cooking pot and components 

as different ingredients that make up your recipe of game play. Unity has lots of different built-in 

component types. 

Step 3: You can create a prefab by selecting Asset > Create Prefab and then dragging an object from the 

scene onto the “empty” prefab asset that appears. If you then drag a  different Game Object onto the 

prefab you will be asked if you want to replace your current game object with the new one. 

Step 4: Write scripts in Unity in C#, a powerful object- oriented programming language. Create 

variables that can be changed in the editor. Detect player input and react to it. Use physics to create 

interactions 

Step 5: Build, test and deploy. 
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Fig 5 Data Flow Diagram for Scene Development 

 

The data flow diagram Advanced vehicular technology is shown in the below Figure 5. 

 

V. PERFORMANCE 

Programs Good performance is critical to the success of many games. Below are some simple guidelines 

for maximizing the speed of your game’s rendering. The graphical parts of your game can primarily 

impact on two systems of the computer: the GPU and the CPU. The  first rule of any optimization is to find 

where the performance problem is, because strategies for optimizing for GPU vs. CPU are quite different 

(and can even be opposite - for example, it’s quite common to make the GPU do more work while 

optimizing for CPU, and vice versa). Fig 6 Illustrates the view for flame test generated in Chemistry lab 

for  various chemical reaction 

 

Fig 6 Flame Test with chemicals 



4976 | D.Roopa                                    Impacting Online Classes With Augmented Reality Based 
Education 

 

a. Image Tracking 

• Static Device Tracker:: This is ideal for applications where the device will remain static, like on a 

tripod or an overhead camera on a workbench. There is no need for the device to first be in motion for 

tracking to start. Perfect for toys, books, or even maintenance scenarios that require the use of both 

hands. Vuforia Engine offers robust and accurate tracking by using the Positional Device Tracker that 

includes tracking a Vuforia target even when the object or content is no longer in the camera view. Note 

that some Vuforia features are  required to run on a Device Tracking supported device. 

• Positional Device Tracker – Learn more on the API behind this capability. 

• Tracking state API results – With the device tracker comes the tracking states that you can use to 

optimize the experience to your user’s needs. 

 

Continued AR Experiences – Learn more on using the states to resume from interrupted and paused AR 

sessions. 

 

b. Status In Object Target Result 

 

The status information provided on Image Target, Object Target Results are identical. The following 

table 1.1 lists the available tracking state values: 

STATU

S 

DESCRIPTION 

 

DETECTED 

This is a transient 

state and not 

observable in 

most cases. 

 

TRACKED 

The trackable is 

being tracked

 and

 indicates 

normal operation. 

 

 

EXTENDED_TRACKED 

The trackable is not 

directly tracked 

with the specific 

tracker. It is either 

out-of-view, too- far 

or too-close to be 

tracked directly 



4977 | D.Roopa                                    Impacting Online Classes With Augmented Reality Based 
Education 

 

 

 

 

LIMITED 

he trackable is 

being tracked but 

only with very low 

accuracy. If your 

application requires 

exact target 

alignment, it is 

recommended to 

discard LIMITED 

poses 

of targets 

 

Table 1.1 Available tracking state values 

 

c. Image Recognition 

Vuforia first detects "feature points" in your target image [Web-based target management] and then uses 

the data to compare the features in target image and the receiving frame from camera. Vuforia uses edge-

detection technique. If there are more vertices or lines in the high-contrast image then its a high rated 

image for Vuforia. So, we can say that their algorithm is somewhat similar to SIFT. Image Recognition can 

be used to build rich and interactive experiences with 3D objects. These experiences could be 

augmenting a toy with 3D content in order to bring it to life, overlaying a user manual on top of a 

consumer electronics device or leading a new employee through an interactive training process for a 

workplace device. Another simple application of Object Recognition is to unlock new in app content 

when a product is recognized 

 

VI. CONCLUSION AND FUTURE ENHANCEMENT 

It was very clear that AR can support teaching and learning, especially with distant learning methods. AR 

reduces cognitive load to a much larger extent. The real challenge of AR Application lies in the usability 

in terms of technical experience and technical problem solving. However, it enables the distant learning 

process to be easier for learners in terms of interaction with their environment as well as in contacting 

face to face with the people around them. Future enhancements include the usage of the Head mounted  

display devices to accelerate the immersive experience especially to develop modules for engineer 

trainees in manufacturing sectors. Teachers now have a powerful tool called Augmented Reality. AR can 

motivate and engage students making the STEM Coding learning process faster, fun and better than ever 

before. 
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